Long Eaton & Sawley Archive

Sawley collection 1
Next


The marina is one of Sawley's best assets, it is currently the largest inland marina in Europe. During the summer, the boating fraternity come here in their thousands.


Another view of the marina showing a few of the many boats moored here.


Always popular during the summer season, this shows a picture postcard view of Trent Lock dated 1907.


A rare colour tinted view on a picture postcard of Harrington Bridge pre 1907. The two toll houses either side of the bridge can be clearly seen. The house to the left is South House.


An early colour tinted postcard showing the road bridge over Sawley Canal.


An aerial view of the River Trent flooding in Sawley 2000. The village can be seen to the bottom right of the picture.


Sawley Baptist Church on Wilne Road was built in 1800 and enlarged to its present size in 1843. It still has a thriving congregation.


The tree lined avenue leading to Sawley All Saints Church. This church is very popular for weddings because of its picturesque setting.


Set in what was once the heart of the village community, Sawley All Saints stands proud on a typical English summer's day.


"The Big Lamp" was situated at Sawley Crossroads. This picture was possibly taken at the time of Queen Victoria's Jubilee. The family standing around the lamp are: Thomas Evans and his wife Emma (nee Allen) with their children: Martha b.1863, John b.1865, Ellen b.1874, Clara b.1870, Walter b.1877 and Henry (Harry) b.1878.


© Copyright 2002 The Long Eaton & Sawley Archive

For more downloads in this series, please visit our web site.

Back