Long Eaton & Sawley Archive

Sawley Parish Church
Flower Festival 2002

Next


This arrangement around the church font symbolizes Baptism.


This colourful display of red Carnations and a traditional Christmas tree represents a typical nativity scene with the manger.


This arrangement of white Lilies, Ivy and Ferns is a portrayal of a wedding ceremony.


A view of the Chancel taken from the Nave of the church, with its magnificent stonework and screen.


The celebration of St Valentine's Day where people declare their love for each other.


The white Lilies contrast beautifully with the gold cross and candle sticks, and the ornate wooden alter to symbolize Sunday Worship.


Here, boy meets girl at the school summer ball. This display encircles one of the church's stone pillars.


Shrove Tuesday, or as some people call it, Pancake Day. Note the bag of flour and the bright display of Oranges and other fruit.


Confirmation into the church is shown here by this display of white Lilies and greenery against the natural stone wall of the church.


The 75th anniversary of the church diocese. The blue Delphiniums take centre stage against the highly polished church pews.


Christ's crucifixion is represented here by the cross, sepulchre and blood red Lilies.


Family days, such as birthdays and holidays, surrounding a central stone church pillar.


A mixture of gold and yellow flowers depict Her Majesty the Queen's Golden Jubilee year.


This brightly coloured Maypole against the church stonework and stained glass window is a celebration of May Day.


All Saints Day, the hooded figure is St Andrew of Scotland alongside a set of bagpipes.


© Copyright 2002 The Long Eaton & Sawley Archive

For more downloads in this series, please visit our web site.

Back